Zenwallet mac critical error at start


latest release:
ZENCash Desktop GUI Wallet for Mac OS 0.74.7

Get red flag when start:
A general unexpected critical error has occurred: com.eclipsesource.json.ParseException: Expected value at 1:1
See the console output for more detailed information

Nov 12 09:31:25 MacBook-Air-mac2 com.apple.xpc.launchd[1] (com.vaklinov.zcashui.4080[717]): Service exited with abnormal code: 3

Название модели: MacBook Air
Идентификатор модели: MacBookAir7,2
Имя процессора: Intel Core i5
Скорость процессора: 1,8 GHz
Количество процессоров: 1
Общее количество ядер: 2
Кэш 2-го уровня (в каждом ядре): 256 КБ
Кэш L3: 3 МБ
Память: 8 ГБ
Версия Boot ROM: MBA71.0166.B30
Версия SMC (система): 2.27f2


hmm try this out

Go to the directory where the wallet.dat is ~ and create a zen.conf file , leave it empty save, and try again.


and how to find out where is zen folder?


for Mac is at: ~/Library/Application Support/Zen (Users > YOURUSER > Library > Application Support > Zen)



conf file was there
it contains


so zen doesnt start anyway
its a pity - i want to start configering 2 nodes


I’ll forward it to our Swing wallet developer


This kind of error typically happens if zend does not start properly. It may happen if there is a blockchain problem or similar. Please examine the debug.log file from zend in directory ~/Library/Application\ Support/Zen/debug.log. This file usually shows the nature of the error.

One thing you may try to fix it, is to start zend manually from a terminal with a command like:
/Applications/ZENCashWallet.app/Contents/Java/zend -reindex
and start the GUI wallet after that.


thank you
it works


I have this same error, but with windows 10. How do I fix it?


Here is the log file:

[main] [Sat Dec 02 09:52:44 PST 2017] [INFO] Starting ZENCash Swing Wallet … [main] [Sat Dec 02 09:52:44 PST 2017] [INFO] OS: Windows 10 = WINDOWS [main] [Sat Dec 02 09:52:44 PST 2017] [INFO] Current directory: C:\Users\TNizzle19\Documents\ZenCash\app [main] [Sat Dec 02 09:52:44 PST 2017] [INFO] Class path: C:\Users\TNizzle19\Documents\ZenCash\app\ZENCashSwingWalletUI.jar;bitcoinj-core-0.14.5.jar [main] [Sat Dec 02 09:52:44 PST 2017] [INFO] Environment PATH: C:\Program Files (x86)\Intel\iCLS Client;C:\Program Files\Intel\iCLS Client;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files\Intel\IntelSGXPSW\bin\x64\Release;C:\Program Files\Intel\IntelSGXPSW\bin\win32\Release;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\Hewlett-Packard\SimplePass;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\QuickTime\QTSystem;C:\Program Files (x86)\Intel\Intel® Management Engine Components\DAL;C:\Program Files\Intel\Intel® Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel® Management Engine Components\IPT;C:\Program Files\Intel\Intel® Management Engine Components\IPT;C:\Program Files (x86)\Skype\Phone;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCommon;C:\Users\TNizzle19\AppData\Local\Microsoft\WindowsApps; [main] [Sat Dec 02 09:52:44 PST 2017] [INFO] Using ZENCash utilities: zend: C:\Users\TNizzle19\Documents\ZenCash\app\zend.exe, zen-cli: C:\Users\TNizzle19\Documents\ZenCash\app\zen-cli.exe [main] [Sat Dec 02 09:52:44 PST 2017] [INFO] zend is not runing at the moment or has not started/synchronized 100% - showing splash… [main] [Sat Dec 02 09:52:44 PST 2017] [INFO] Splash: checking if zend is already running… [main] [Sat Dec 02 09:52:45 PST 2017] [INFO] unexpected daemon info:
[main] [Sat Dec 02 09:52:45 PST 2017] [INFO] Splash: zend already running… [main] [Sat Dec 02 09:52:49 PST 2017] [INFO] unexpected daemon info:
[main] [Sat Dec 02 09:52:51 PST 2017] [INFO] unexpected daemon info:
[main] [Sat Dec 02 09:52:54 PST 2017] [INFO] unexpected daemon info:
[main] [Sat Dec 02 09:52:56 PST 2017] [INFO] unexpected daemon info:
[main] [Sat Dec 02 09:52:59 PST 2017] [INFO] unexpected daemon info:
[main] [Sat Dec 02 09:52:59 PST 2017] [ERROR] Unexpected error:
java.io.IOException: com.eclipsesource.json.ParseException: Unexpected end of input at 1:1 at com.vaklinov.zcashui.ZCashClientCaller.getDaemonRawRuntimeInfo(ZCashClientCaller.java:198) at com.vaklinov.zcashui.StartupProgressDialog.waitForStartup(StartupProgressDialog.java:131) at com.vaklinov.zcashui.ZCashUI.main(ZCashUI.java:564) Caused by: com.eclipsesource.json.ParseException: Unexpected end of input at 1:1 at com.eclipsesource.json.JsonParser.error(JsonParser.java:490) at com.eclipsesource.json.JsonParser.expected(JsonParser.java:484) at com.eclipsesource.json.JsonParser.readValue(JsonParser.java:193) at com.eclipsesource.json.JsonParser.parse(JsonParser.java:152) at com.eclipsesource.json.JsonParser.parse(JsonParser.java:91) at com.eclipsesource.json.Json.parse(Json.java:295) at com.vaklinov.zcashui.ZCashClientCaller.getDaemonRawRuntimeInfo(ZCashClientCaller.java:194) … 2 more



Go to the folder where you saved “ZenCashDesktopGUIWallet.exe” Hold Shift and Right click in the folder window (in the white space). Click on Open PowerShell Window here: then type in: .\zencashdesktopguiwallet.exe


I got this error message at start.
Wallet version:ZENCashDesktopGUIWallet_0.74.2
Operation system: Windows 10 64bit.
How can I fix it?


Getting an error when starting my wallet on windows. “createprocess error=193, %1 is not a valid win32 application”. What is the recommended approach from here?


I got the same error message when I restarted the GUI Wallet on Windows 10 after I tried to initialize a new wallet and it crapped out because my system went to sleep after two hours. The only way around it was to copy all of the files from my AppData/Roaming/ZCashParams and Zen folders to another location, delete those folders, and re-initialize the wallet. I changed my “sleep” setting so it never sleeps, then started to initialize the new GUI wallet at 8:30pm last evening. Now at 9:30am this morning it’s only 23% synced!

So how many DAYS should this sync process take? My CPU is running at 100%, everything else has slowed to a crawl; I have an I7 CPU with 8GB of RAM, so no lack of resources for this process to use!


Thanks for your help. now I am in the sync process. It takes time I think.
How can I retrieve my wallet data after the sync process finish?


It seems you have the known problem of a broken blockchain. Please check this troubleshooting guide that explains the problem and how to fix it: https://github.com/ZencashOfficial/zencash-swing-wallet-ui/blob/master/docs/TroubleshootingGuide.md


You need to have a 64-bit Windows OS with at least 8 GB RAM. It seems you have a 32-bit system…


The wallet.dat file contains the ZEN private keys. It needs to be kept safe from data loss (e.g. via regular backups). This file may be copied/replaced manually but only if the GUI wallet and zend are not running.


ok, fixed now. thank you very much.


Negative, running a windows 64 bit operating system. Was previously working, just getting the error now after 2 weeks of successfully running the wallet.