Zen.conf Example


#1

I believed I done most of secure node setup at 1 and 2, however got stuck at the zen.conf. Can anyone help on this?

Within the zen.conf:

addnode= IP address , — Can I assume the IP address of the secure node? From the instruction, the “peers”, which peer?

connect= IP address, Same as above?

rpcuser and rpcpassword — Where I can create/seup the user and password? at zencash site?

rpcallowip — Which IP address? My secure node ip address? My server is with public IP address, any security concern?


#2

Hi there,

At the very basic configuration you need the following:

rpcusername=somethingRandom
rpcpassword=Somethingreallycomple3x
rpcport=18231
rpcallowip=127.0.0.1
server=1
daemon=1
listen=1
txindex=1
logtimestamps=1
tlskeypath=path/to/your/ssl/key
tlscertpath=path/to/your/ssl/cert

addnode= and connect= are not needed to get you up and running


#3

Thank you! I modified the file base your suggestion. When I run the zen-cli getinfo,
it show as follow:

“version”: 2001051,
“protocolversion”: 170002,
“walletversion”: 60000,
“balance”: 0.00000000,
“blocks”: 0,
“timeoffset”: 0,
“connections”: 0,
“proxy”: “”,
“difficulty”: 1,
“testnet”: true,
“keypoololdest”: 1516412449,
“keypoolsize”: 101,
“paytxfee”: 0.00000000,
“relayfee”: 0.00000100,
“errors”: “WARNING: check your network connection, 0 blocks received in the last 4 hours (96 expected)”

What could be the problem? Can you help?
I also check the node list at testnet, my node is not in the list. It is running on a VPS with no firewall enable yet (will be enable once I got some response) and it is on a public IP.


#4

You’ll always get this warning the first time that you run zend. Do you get it still if you stop zend and restart it?


#5

Hi ChiensNode,
In case this is still a puzzlement, it’s letting you know that your node’s copy of the blockchain is still being synchronized. Check it from time to time and compare it with the current block height, which you can find here:

https://explorer.zen-solutions.io/

Here’s an example showing the block height at the right:

Hope this helps.


#6

Thanks! It all good now. Node is running for a while, however still will get the downtime email for no reason. Check the nodes itself and is showing up and running. But other then this, all good!

Thanks!


#7

Good to hear your node is running well now.

I get those notifications from time to time myself, and most often the downtimes log shows the host as being unreachable for a few minutes. It’s not clear why this happens, but we should remember that the tracking site is still in beta testing.