Zen coins and transaction history are missing after .tar import


Hello Support!
So i have been away from my computer for some time. I came back to see there has been a hard fork and new wallet available. I downloaded the new wallet version 0.0.9, imported my .tar file and none of the transaction history nor my 600 zencash are showing up to the wallet.
The wallet shows 100% sync.
the previous wallet version that i was running was 0.0.5.
am i doing something wrong or did i just lose my ZEN?


Sorry to hear of the issue! The important file is the wallet.dat with all your prior private keys, so make sure you have that file available and when you have the newest version installed, swap in the old file.

On Mac, your wallet.dat is located:

~/Library/Application\ Support/Zen


It is an issue with Eleos. What you need to do is restore the Appdata Zen folder back to how it was at ver 0.0.7 then delete the subfolders within the Zen Folder. Then download the Swing Zencash wallet and load that up. It will load up the wallet.dat and you will have all your coins back. The Eleos wallet is very flawed.


Thanks for the description…we ought to consider taking down Eleos from the GitHub soon, especially since we don’t intend to continue supporting it.


I have the same issue, I have tried importing my wallet.dat file into both swing and eleos but after syncing 100% neither show my missing coins. How can I fix this?

Furthermore swing states the private keys have been successfully imported.


have you tried the fix from @Regulater above? Also consider popping into the #developers channel in our Slack if that doesn’t work; almost always someone there who works on these wallets regularly.


yes it did not work. I am trying to import into swing 0.70.3; using the import button as before successful import, 100% sync, no change.

Manually swapping the files and restarting swing; results in an error and the swing starts with a new wallet file.

I will try slack. thank you :slight_smile: