Secure node Linux help!


I am trying to create a secure node on my new vps but I am far from a Linux user! I spend more time in Windows and SQL, so I am not used to all of the Linux controls. This is the project that I am hoping to get proficient in Linux but I am pulling my hair out!

I am at the step to add the ip address to sudo vim /etc/hosts but when it pulls up I can’t add any lines, I have tried to get into insert mode and I think I finally did. “I” but after adding everything I don’t know how to ensure it saves or how to check if it worked. So I found a site that mentioned to hit “:w” to save now I am stuck without a command line, so I reboot. When I reboot and go back to ensure it worked it tells me that there is either two files or an open file. So if I hit R it takes me to the same file and if I hit D it takes me to that same screen. Help what am I messing up, and what command will bring the command line back?


UPDATE your linux distro to 12.4 LTS you are using a older build of ubuntu


Also - try using nano rather than vim - it’s more intuitive for the windows user (sudo nano /etc/hosts)
then ctrl+x when finished editing


In Vim
i - insert mode
esc - exit insert mode (command mode)
:w - write to disk (save)
:q - quit
:wq - save and quit
ctrl-v - visual block (select)
y - yank(copy)
shift-P - paste
d - delete

Those are the main commands that I use most. There are a lot of other commands that help you navigate around the text faster, but I mostly just use arrow keys for that. All those commands except for “esc” should be used in command mode. If you need to paste text that you copied outside of the terminal, then you right-click the terminal when it’s in insert mode and select paste, though that may not work if you’re using putty to ssh, I’m not sure.


Thanks I got through that portion but now I am getting a failure in the installation from github (not to mention the darn keygen from Putty does not work) I get this error on installation what did I miss?


And the Zend application is not in the source file, do you think the all-recurive has to do with it?


you used “dir”. use “ls” to list all files in the directory.


@gumbi17 HI there, Did you ever get sorted with this problem? I’ve got the same issue.