Process 'zend' status Execution failed


I have one of my nodes that is driving me crazy.
I can’t manage to fully configure it, since it keeps me giving this answer when I type “sudo monit status”

I have tried deleting and recreating the conf file, renewing the SSH certificate, re-starting the monitoring procedure, etc. but nothing worked. Someone knows what could be causing this issue?



Still I can’t manage to get rid of the issue… in some of my nodes “zend” says status monitored, in others it doesn’t.
Despite this, everything seems to work fine, challenges are passed etc… but I’d like to understand why it’s behaving like this


Have you found any solution?


not yet, still getting this issue from then in then


did you ever figure this out? i just passed a challenge but monit status shows the same “execution failed” for me


Did anyone else figure out this issue?

My first node status is working, but my other nodes all have execution failed just like the image posted in the first post.


I had this issue. I found that I had not updated the username in the details added to monitor zend at the end of the /etc/monit/monitrc file.

I had not updated the following line:

check process zend with pidfile /home/<USER>/.zen/

once I updated the <USER> to the correct username and reloaded with:

sudo monit reload

sudo monit start zend

sudo monit status

The monitoring results were provided correctly.

Hope this helps.


thanks for the insight. I will take a look.


hi guys i have the same issue , and i tried this solution and it didn’t work for me , any idea guys please ??


I eventually managed to solve this issue on all my nodes.
In my case, there was an error in “” file, I just pasted the code wrongly.
then, obviously, running the script at start was not possible, and running chmod u+x ~/ pointless.

I uninstalled monit, deleted conf files, reinstalled monit again, and now it’s working properly.

Also, check this link and be sure your pm2 version is correct.

Hope this helps.