Lost Zen Please Help


Hi there,

I downloaded the eleos wallet and sent 55 zen to a transparent wallet address, which I could see on my balance.
Unfortunately I didn’t back up my wallet and my hard drive died. I had the data recovered onto an external hard drive but when I opened the wallet from the hard drive and the wallet synced the coins were no longer in the wallet.
Is there any way to recover my zen? I’ve searched for the .tar files and wallet.dat files but can’t find anything.
Please help!!


I’ve found the wallet.dat file but it just seems to be empty.



If you’re on Windows I might be able to assist you.
Firstly make sure you have the correct wallet.dat file.
If the data recovery kept the original directory structure, then you should look for it here on the external drive :
Users\ (your username) \AppData\Roaming\Zen

Copy the wallet.dat file to %appdata%\zen on your working system.
Open the Eleos wallet and wait till 100% sync, after that all your coins should be there.
If not then your wallet.dat file probably is corrupt and you lost the coins.




Thanks very much for the reply L.

I’m on Mac. Would this be a similar process on Mac?

I’ve located the wallet.dat file on the external hard drive in Users/Library/Application Support/Zen.

When I initially opened the wallet from the external hard drive the wallet took about 15 minutes to load but then the sync status says NaN% with 0 connections. There aren’t any receive addresses and no history just like a new wallet. I’m afraid that if I try reinstalling the wallet that I’ll do the wrong thing somewhere. I’m not very technical unfortunately.

Surely I must be able to get the coins back because as far as I know all the data was recovered and is sitting on my external.

I hope someone has had this problem before and is able to give me a step by step guide to recovering the coins.

Any help would be greatly appreciated as I’ve been pretty down after losing the coins. It’s a lot of money for me.



You can try loading the wallet.dat file via myzenwallet.io


Hi Kendrick,

Sorry, Could you explain the process in a bit more detail please?

Do I have to create my own seed phrase for this wallet? Never seen that before.


Sorry I’m just reading through the getting started section.


Nothing happens when I click on load wallet.dat file in the settings section


If you click load the ‘load wallet.dat’ button on the settings page and close the page you should be presented with a ‘Select wallet.dat file’ button back where the secret phrase was.


Ok sorry yes I got there and loaded the wallet.dat file and about 80 addresses popped up all with a balance of 0. I must have the wrong file. I’m not sure.


Sorry no here.

At least I know my coins are still in the wallet. I’m sure I wasn’t given a seed phrase when I downloaded the eleos wallet. I transferred a small amount to make sure I was transferring to the correct address and after sending the rest I was complacent because I new the coins were there and was planning to move them. So annoyed at myself.


Any advice on how to get eleos to sync?
It says 0 Connections
Sync Status NaN%
I can see other people have had this problem on GitHub but couldn’t find a solution or cause.
How can I get help on this!!


Locate the zen.conf file and add below lines to it for a quicker wallet sync :



Hello Ivanhaes,

Thanks very much for your help and time.

I’ve followed your instructions and the wallet is starting to sync. :joy:

Connections 3 and Sync Status: 17.5%

Man If this works you are an absolute legend.

Will keep you posted.




I’m trying to sync my eleos wallet and it is stuck at 86.8% with 8 connections and doesn’t seem to be moving from there for quite some time.

Any advice?


Hey dude,

As long as you have x connections it should eventually fully sync.
Sometimes it can take a really long time, like hours and hours.
Just let it run.

Kudos for the zen.conf file go to @Blockops
Good luck !



Hey L,

Thanks for the reassurance.

It’s been about another 24 hours and still 8 Connections but Sync Status is now 86.5%

Hopefully it starts moving in the right direction at some stage.

Cheers to @Blackops for helping

Appreciate the help.



Close and reopen, it shouldn’t take that long to go up.
It appears to be stuck somehow.
Rinse and repeat, eventually it should work.
Also make sure you have the latest version 0.9 of the Eleos wallet software.

Cheers !



Ok Thanks will give it a go.

I’m getting a corruption error once the v 0.9 is downloaded.

telling me to run “sudo spctl --master-disable” first.

Won’t that mean I am disabling the version that has my coins on it?

What files do I need to drag over from my external hard drive so that the
complete wallet is on my computer and I can disable the hard drive?
Is it just the 2 folders in the application support folder “zen” and “eleos” that I need?

I’m starting to get a little concerned here.



I tried running version 0.9 and it wouldn’t open.

“Couldn’t find wallet daemon”

lvanhaes if you can help me through this I will tip you 1 zen.

I have version 0.7 on the external which I have been trying to sync. and is now stuck.

I’ve downloaded 0.9 but it won’t run because “wallet can’t find daemon”

Is it possible to take the files in the version 0.7 and put them into the 0.9 version?

I tried running “sudo spctl --master-disable” and nothing happened.

OMG! Please help. :sob: