Installing securenode 2.0.14 RC1 on testnet


#1

Hi Zen community,

I’m trying to install my first securenode on testnet. I successfully compiled 2.0.14 RC1 and the blockchain synced on testnet. I was glad to see the result of the bench : 170 seconds :slight_smile:

The problem is however that i’m stuck in the installation procedure at the certificate step …
Following this guide here : https://documentation.zencash.com/display/ZEN/Part+6+-+Procure+and+Configure+Certificate
Part 3 says to copy a file to /usr/local/share/ca-certificates/chain.crt
But the folder “/etc/letsencrypt/live” actually does not exist … so i searched for some ‘*.pem’ files in parent folder “/etc/letsencrypt/” and found some in “keys” and in “csr”.
I wonder if i can use these, but i guess they won’t be renewed ??

Update :
Well, after skipping this step and going further in the installation process, i encountered another error in Part 8 : installation of “secure node tracker”
Installation of npm results in an error : “Error: invalid version”

I don’t know if these 2 errors are related, but i suspect that something went wrong with my certificate trick, as i’m getting another error when trying to clone the securenodetracker git repo :
fatal: unable to access ‘https://github.com/ZencashOfficial/secnodetracker.git/’: Problem with the SSL CA cert (path? access rights?)

Well … i’m not ready yet to get a production securenode this month :smiley:
I’ll have to practice more and redo the whole installation. :stuck_out_tongue:

Any clues ?

Thanks

Update 2 :
Removing the tricky certificate in “/usr/local/share/ca-certificates/chain.crt” solves two points :

  • npm now installs
  • git clone also works

:wink:

i continue …


#2

Hi @tof,

may I ask you to join our channel #testnet-config on Discord (you can use this link https://discord.gg/skuxxrW), please? One of our engineer suspects the initial problem reported pertains to the certificate not being issued.

Thank you very much :blush:

Have a great day!

Kamila
Community Project Manager of ZenCash


#3

Yes sure, i already am conected to ZenCash’s Discord, but didn’t have enough time yet to dig deeper.
Your engineer is right, the problems come from the certificate generation process failing …
(i had to remove the ‘cert’ lines from zen.conf too because it no longer received blocks nor connections)

Thank you for your reply, have a great day too ! :slight_smile: